+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2012
    Posts
    42
    Thanks
    13
    Thanked
    5
    Reviews
    0

    Default What is wrong with me?

    Hi everyone,

    Today's CD 18 and according to my charting I am 5dpo. I had a very early miscarriage last month, took clomid this cycle on days 2-5 and had an ovidrel injection on CD 12 (last Friday).

    Nearly 2 hours ago I felt a little moist, went to the toilet and there was a streak of dark blood on my underwear. When I wiped there was a whole pool of watery dark blood. I went to the toilet about 40 mins later, no more on underwear but another big lot when I wiped, this time a rusty type colour and watery. I have also had a few shar pines on both sides.

    Does anyone have any experience with this? I am currently sitting at a hospital waiting to be seen for an injury to my knee (not sure what caused it). I will ask the hospital what they think but I am really worried. We have been trying for 7 months and I just thought this could be our lucky positive month.

  2. #2
    Join Date
    Mar 2012
    Posts
    481
    Thanks
    198
    Thanked
    65
    Reviews
    0
    Could it be old blood left over from the misscarriage possibly? Or may be implantation bleeding


 

Similar Threads

  1. Where did I go wrong?
    By diesal444 in forum Breastfeeding Support
    Replies: 10
    Last Post: 01-06-2012, 15:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
FEATURED SUPPORTER
Ultimate SleepHad a wonderful, uninterrupted sleep? Luxury Australian made, hypoallergenic & machine washable products so everyone ...
FORUMS - chatting now ...
REVIEWS
"Made bed time less anxious"
by Meld85
My Little Heart Whisbear - the Humming Bear reviews ›
"Wonderful natural Aussie made product!"
by Mrstwr
Baby U Goat Milk Moisturiser reviews ›
"Replaced good quality with cheap tight nappies"
by Kris
Coles Comfy Bots Nappies reviews ›